Wednesday, June 24, 2009

Eclipse Galileo 3.5 plugins for GWT development

Please look at the newer post:




1) Upload a new version of Eclipse Java EE IDE for Web Developers 3.5 Galileo (Mac Cocoa)


to add plugins you open: "Help -> Install New Software..."







Restart Eclipse each time you are being asked.
In similar fashion add other plugins...

2) SVN plugin - http://subclipse.tigris.org/update_1.6.x

No problems with installation.

3) Google GWT AppEngine plugin - http://dl.google.com/eclipse/plugin/3.4

Cannot complete the install because one or more required items could not be found.
Software being installed: Google App Engine Java SDK 1.2.1 1.2.1.v200905131143 (com.google.appengine.eclipse.sdkbundle.e34.feature.feature.group 1.2.1.v200905131143)
Missing requirement: Google Plugin for Eclipse 3.4 1.0.1.v200905131143 (com.google.gdt.eclipse.suite.e34.feature.feature.group 1.0.1.v200905131143) requires 'org.eclipse.platform.feature.group [3.4.0,3.5.0)' but it could not be found
Cannot satisfy dependency:
From: Google App Engine Java SDK 1.2.1 1.2.1.v200905131143 (com.google.appengine.eclipse.sdkbundle.e34.feature.feature.group 1.2.1.v200905131143)
To: com.google.gdt.eclipse.suite.e34.feature.feature.group 1.0.1


4) Maven2 plugin - http://m2eclipse.sonatype.org/update/

Cannot complete the install because one or more required items could not be found.
Software being installed: Maven Integration for AJDT (Optional) 0.9.8.200905041414 (org.maven.ide.eclipse.ajdt.feature.feature.group 0.9.8.200905041414)
Missing requirement: Maven Integration for AJDT (Optional) 0.9.8.200905041414 (org.maven.ide.eclipse.ajdt.feature.feature.group 0.9.8.200905041414) requires 'org.eclipse.ajdt.feature.group 1.5.0' but it could not be found