Tuesday, April 7, 2015

Error:java: javacTask: source release 1.6 requires target release 1.6

Error:
Error:java: javacTask: source release 1.6 requires target release 1.6


For some reason IntelliJ started to DEFAULT to Java 1.5 on all my new projects, to fix that you go to:

IntelliJ IDEA > Preferences... > search Compiler > Java Compiler


  • select what default you want
  • adjust using drop-down your existing projects